Articles
   
       
Pics/Video
       
Wake 101
   
       
       
Shop
Search
 
 
 
 
 
Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
WakeWorld Home
Email Password
Go Back   WakeWorld > Boats, Accessories & Tow Vehicles

Share 
Reply
 
Thread Tools Display Modes
Old     (Joregon)      Join Date: Oct 2016       06-21-2020, 11:57 AM Reply   
I have a 2004 centurion elite v with a MerCruiser 350 MAG EFI that is slow to start and when it does, the idle is around 500, even when cold. is this controlled by the IAC valve? seems like it should idle a bit higher to start and then idle down after warming up.

Anything else I should look into? I am unsure how idle is controlled otherwise.

thanks!

Edit, I believe the previous owner replaced with a less expensive non-mercruiser part (automotive, not marine grade). not sure if that is pertinent but thought I would throw it out there.

Last edited by Joregon; 06-21-2020 at 12:02 PM.
Old     (GSXRcrasher)      Join Date: Jul 2013       06-24-2020, 11:08 AM Reply   
I have a 97 mercruiser black scorpion MPI 350 in my boat and a couple of years ago had problems with occasional hard starts and occasional loss of power. I replaced my distributor cap and that helped a bit but the main problem ended up being a bad fuel pressure regulator. The regulator was located pretty low near the back of the engine and a vacuum line had been knocked off of it at some point. Iím not sure if bilge water got in thru the vacuum line hole while the line was knocked off, but the regulator was still not working with the line re-attached. I replaced the regulator and that fixed my problems. Maybe check fuel your fuel pressure?
Old     (denverd1)      Join Date: May 2004 Location: Tyler       06-25-2020, 3:10 AM Reply   
does it start/run better when warm?

check diz cap, rotor, contacts in the cap. replace if it's been a while (several hundred hours)
check plugs for fouling
fuel pressure is a good one, could indicate a pump problem. hook up fuel pressure gauge to the fuel rail
Old     (TTyler89)      Join Date: Jun 2015       06-27-2020, 3:15 AM Reply   
My money is on the IAC. I don’t care how recent it was replaced, if it’s an automotive replacement it will not hold up to a marine environment. Distributor cap and rotor will smooth the motor up tremendously but not to the point that it won’t idle or start when cold. The idle is controlled by the ECU, it regulates idle with the IAC. More air it lets in higher the idle, and less air it lets in the lower the idle.

Last edited by TTyler89; 06-27-2020 at 3:21 AM.
Old     (TTyler89)      Join Date: Jun 2015       06-27-2020, 9:32 AM Reply   
Also if a cap and rotor and plugs haven’t been done for several years, I’d go ahead and do that as well. You’d be amazed at what a difference it makes in the way it runs. Since it’s a mercruiser, look on the big plastic breather cover for what spark plugs it calls for. Cross reference that over to ngk plugs and get those instead of the ac delcos. Also look for the plug gap on the breather cover and gap your new plugs to spec. If they are iridium or platinum plugs take care not to pry on the electrode when gapping as you will ruin them.
Old     (Joregon)      Join Date: Oct 2016       07-12-2020, 2:31 PM Reply   
good idea, GSXRcrasher. I had not considered the fuel pressure. I'll see if i can't figure out how to look at that. thanks for the reply.

denverd1, it does run a little better when warm. i'd say it doesn't appear to be idling any higher, it just seems more smooth and consistent.

TTyler89, i'm wondering if the IAC is ultimately going to be the solution. from what I have heard, it should notice if there's a difference in starting cold vs starting warm so maybe a marine grade IAC is the right way to go? It's fuel injected so no rotor to replace. but the plugs would be a good idea. thanks for the tip on the brand. i really appreciate it.

Last edited by Joregon; 07-12-2020 at 2:36 PM. Reason: added text
Old     (TTyler89)      Join Date: Jun 2015       07-13-2020, 11:35 AM Reply   
The only way it won’t have a cap and rotor is if it’s got individual coil packs and I’m fairly certain mercruiser only had individual coil packs back then on like the bbc 496 mag. I could be wrong. The coil packs will be on the valve covers if it has them. Even though it is fuel injected, Mercruiser, Volvo penta, pcm, indmar, etc. all ran distributors on the sbc up until the release of the new ls based motors. Which was just a few years ago. If it has the flat crab cap on the distributor, those are notorious for causing problems. They eventually short themselves out internally and the spark never makes it to the plug wire. If it was mine I’d pull the cap and look at the contacts. If they have a bunch of green corrosion built up on it, replace it and the rotor. If not put it back on and move on to the IAC. If it in fact does not have a distributor, id go straight to the IAC.
Old     (grant_west)      Join Date: Jun 2005       07-13-2020, 2:13 PM Reply   
I have a Merc 350 HO Mag it's the 5.7L V8 its in my Pontoon Boat.it has 1700 Hrs on it It's a 2012 It had a rough Idle & the Digital Dash was showing "Misfire & ODB sense" Error codes on the dash. Replacing the Spark plugs fixed my issue.
Old     (Joregon)      Join Date: Oct 2016       07-14-2020, 5:03 PM Reply   
TTyler89, obviously I have no idea what I'm talking about. :-) I'm going to bring it to the boat doctor since it's definitely over my head. I'll poke around but I'm afraid I might make it worse. Thanks for the suggestions. I really appreciate it!
Old     (Joregon)      Join Date: Oct 2016       07-21-2020, 11:50 AM Reply   
Last update on this thread: I took it to the boat mechanic. Apparently on Mercruiser engines there is a filter near (or inside) the IAC. Mine was plugged and needed to be replaced. Apparently one 1/2" x 1/2" sponge costs $150.00 in parts and labor. Actually better deal than I was expecting so I'll take it, gladly. Just thought I would post in case someone else has a similar issue.
Old     (GSXRcrasher)      Join Date: Jul 2013       07-22-2020, 5:35 PM Reply   
Thanks for taking the time to update us with what the problem was. Now I need to check if my 1997 Mercruiser black scorpion has this filter. Probably time to replace mine if it does.
Old     (Joregon)      Join Date: Oct 2016       07-24-2020, 7:04 AM Reply   
GSXRcrasher, my mechanic said it was common to Mercruiser. is your's efi? I took the boat out last night and it's never idled this good so i'm happy about that. the downside is I have a new noise from my transmission. Good luck!
Old     (GSXRcrasher)      Join Date: Jul 2013       07-24-2020, 8:38 AM Reply   
Yes my 1997 mercruiser black scorpion is a multi port fuel injection engine. Hopefully someone on here knows if mine has the same filter. Good luck with the transmission noise.
Old     (TTyler89)      Join Date: Jun 2015       07-26-2020, 9:26 AM Reply   
Joregon- Awesome! I’m glad to hear you got fixed up and running again. It sux chasing down issues like that as it takes the enjoyment off the water. That little muffler is just that. It’s not any sort of filter, it’s just a muffler to silence the hissing noise the intake makes from the IAC circuit. If it is stopped up, then that will most definitely cause idle issues. I typically remove them but occasionally some customers don’t like the added intake noise and I replace them. I honestly had forgotten about those as that’s not an item that goes bad very often.

GSXR- yours probably won’t have it as I don’t think mercruiser started putting those in until early 2000’s but I could be mistaken. You can definitely put one in if yours has the multi port injection. It just sits in the square port in the throttle body.
Old     (GSXRcrasher)      Join Date: Jul 2013       07-26-2020, 10:46 AM Reply   
Thanks for the heads up Tyler. With a bit of searching I saw talk of the muffler definantly being on some black scorpion engines. I will probably pull off my intake plenum and take a look at some point.

Reply
Share 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -7. The time now is 4:08 AM.

Home   Articles   Pics/Video   Gear   Wake 101   Events   Community   Forums   Classifieds   Contests   Shop   Search
Wake World Home

 

© 2019 eWake, Inc.    
Advertise    |    Contact    |    Terms of Use    |    Privacy Policy    |    Report Abuse    |    Conduct    |    About Us